Announcement

Collapse
No announcement yet.

Front brake issue since F body conversion

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Front brake issue since F body conversion

    So, about 3 years ago, I put on the F body conversion. everything went on smooth. Problem was when I would drive, I would get a rotation squeak ONLY when I turn left . So, I riped it off about 5x. Check clearances, etc., and it would always come back. So, in teh garage it went, and I spent the last 3 years re-doing the entire truck. Put a new master and proportioning valve in it. Just took it on my street, and the squeak is still there. I am at a total loss. The caliper I purchased 3years was brand new, same with the rotor. The F body adaptor bracket is from a vendor (can't remember which one), but I am about to rip it all off and start over. Any thoughts? Could it be a bad caliper? Or do you think the bracket is bad? I am very lost and frustrated.

  • #2
    You greased the back of the pads already I assume?

    I'd probably check the run out on the Hubs too.

    Comment


    • #3
      Thank you for the reply. It gives me something to check...
      Pads I have greaser, regreased, checked multiple times...
      Run out on hubs? What do you mean (Sorry, I dont understand). I changed hubs thinking it was that, and it still occurred.

      Comment


      • #4
        Run out meaning the amount of movement in the hubs across their circle of travel - but if you changed them then that answers that question.

        Is it only one side?

        Comment


        • #5
          Yes, only the pass side only when I turn to the left, not straight....

          Comment


          • #6
            DO you think it could be a bad caliper? I was thinking of changing it out. It is new (reman), but I am at a loss

            Comment


            • #7
              Before I did that I'd change the pads from drivers side to passenger side.

              Comment


              • #8
                Do you still have splash shields on the back side of the rotors? I once had a squeak from a splash shield that would just barely touch in a turn. Took awhile to find.

                Comment


                • #9
                  Dave,
                  Splash shield not in it, but that gives me an idea...
                  I will go take a look tonight...
                  the thing that bothers me is that it is with rotation, and speed, but only when turning left...

                  Comment


                  • #10
                    What about the sheet metal inserts that go into the caliper bracket to hold the pads. Could one be out of alignment enough that it’s hanging over past the bracket and the rotor is deflecting enough to hit it? Wouldn’t take much, there’s very little clearance there and the inserts although they snap into place it isn’t exactly a precision fit.

                    Comment


                    • #11
                      Originally posted by RealFastV6 View Post
                      What about the sheet metal inserts that go into the caliper bracket to hold the pads. Could one be out of alignment enough that it’s hanging over past the bracket and the rotor is deflecting enough to hit it? Wouldn’t take much, there’s very little clearance there and the inserts although they snap into place it isn’t exactly a precision fit.
                      This is what it was. I found a article on Fbody forum. I can't believe thats all it was.... Crazy!

                      Comment


                      • #12
                        Originally posted by ty0234 View Post

                        This is what it was. I found a article on Fbody forum. I can't believe thats all it was.... Crazy!
                        Nice. Glad you found it.

                        I was putting my brake kit together on the Ty last night and it occurred to me as a possibility.

                        Comment

                        Working...
                        X